WordPress的Aliyun OSS插件不支持PHP8.0

在WodPress中的远程附件(阿里云)插件莫属于Aliyun OSS是最老牌也最棒的插件。

昨日我将服务器的LAMP环境改了PHP扩展,升级了PHP版本到8.0,发现附件无法上传。

Aliyun OSS
Aliyun OSS

问题排查方法:

  1. 首先是百度,网上的什么资源不够哦,缺少GD、IMAGIC库哦,都不是我遇到的问题
  2. 停用Aliyun OSS之后发现可以了
  3. 再启用Aliyun OSS,怀疑是不是设置的OSS的key等失效,重新配置,保存,发现会出错,于是换到PHP7.4,OK了

Aliyun OSS目前最高支持PHP 7.4,并不支持8.0.

参考文章:
https://github.com/yiichou/aliyun-oss-support/issues/125

分类 WordPress技巧 本文由 清白之年 原创发布,转载请注明文章来源。

发表评论

您的电子邮箱地址不会被公开。