WordPress 5.0.1安全更新版本,推荐更新

WordPress 5.0.1现已推出。 这是自WordPress 3.7以来所有版本的安全版本。 我们强烈建议您立即更新您的网站。

  • Karim El Ouerghemmi 发现:「作者」权限的用户可以通过改变 meta 数据来删除他们没有权限的文件。
  • Simon Scannell of RIPS Technologies 发现:「作者」权限的用户可以通过特制的输入来创建他们没有权限的文章类型的文章。
  • Sam Thomas 发现:「贡献者」权限的用户可以使用一种特制的元数据导致 PHP 对象注入。
  • Tim Coen 发现: 「贡献者」权限的用户可以编辑来自较高权限用户的新评论,从而可能导致跨站点脚本漏洞
  • Tim Coen 还发现: 在某些情况下,特制的URL输入可能会导致跨站点脚本漏洞,WordPress 本身并没有受到影响,但是插件可能会受到影响。
  • Team Yoast 发现: 在一些不常见的配置中,用户激活界面被搜索引擎索引,从而导致电子邮件地址暴露,并且在极少数情况下,还会默认生成密码。
  • Tim Coen 和 Slavco 发现:Apache 托管网站上的「作者」权限的用户可以上传一些特殊的特制文件,这些文件可以绕过 MIME 验证的,从而导致跨站点脚本漏洞。

WordPress 5.0.1 is now available. This is a security release for all versions since WordPress 3.7. We strongly encourage you to update your sites immediately.

Plugin authors are encouraged to read the 5.0.1 developer notes for information on backwards-compatibility.

WordPress versions 5.0 and earlier are affected by the following bugs, which are fixed in version 5.0.1. Updated versions of WordPress 4.9 and older releases are also available, for users who have not yet updated to 5.0.

  • Karim El Ouerghemmi discovered that authors could alter meta data to delete files that they weren’t authorized to.
  • Simon Scannell of RIPS Technologies discovered that authors could create posts of unauthorized post types with specially crafted input.
  • Sam Thomas discovered that contributors could craft meta data in a way that resulted in PHP object injection.
    Tim Coen discovered that contributors could edit new comments from higher-privileged users, potentially leading to a cross-site scripting vulnerability.
  • Tim Coen also discovered that specially crafted URL inputs could lead to a cross-site scripting vulnerability in some circumstances. WordPress itself was not affected, but plugins could be in some situations.
  • Team Yoast discovered that the user activation screen could be indexed by search engines in some uncommon configurations, leading to exposure of email addresses, and in some rare cases, default generated passwords.
  • Tim Coen and Slavco discovered that authors on Apache-hosted sites could upload specifically crafted files that bypass MIME verification, leading to a cross-site scripting vulnerability.

Thank you to all of the reporters for privately disclosing the vulnerabilities, which gave us time to fix them before WordPress sites could be attacked.

Download WordPress 5.0.1, or venture over to Dashboard → Updates and click Update Now. Sites that support automatic background updates are already beginning to update automatically.

原文地址:https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/

发表评论

电子邮件地址不会被公开。 必填项已用*标注