WordPress 5.0禁用古滕堡编辑器的方法

WordPress 5.0正式版使用了古滕堡编辑器,非常不习惯,之前我提到过,可以使用Classic Editor经典编辑器做为插件方式。

还有一个方法就是禁用古滕堡编辑器,在你的WordPress主题的functions.php中插入代码禁用。下面总结下WordPress 5.0禁用古滕堡编辑器的方法:

第一步:

1、使用Classic Editor经典编辑器插件

2、WordPress主题中的functions.php加入:

add_filter('use_block_editor_for_post_type', '__return_false');

注意:上面二选一即可。

第二步:

WordPress 5.0会在前端默认加载 wp-block-library-css 作为古滕堡的适配:

wp-block-library-css
wp-block-library-css

去掉这段css,在functions.php中加入:

wp_deregister_style('wp-block-library');

发表评论

电子邮件地址不会被公开。 必填项已用*标注